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Chapter 1 Using Direct Database Drivers

OVERVIEW

S-PLUS now includes access to the following databases via direct
database drivers:

*  Microsoft SQL Server (Windows only)

« IBM DB2 (Windows, Solaris 32, Linux, Compaq Tru64, HP,
AIX)

+  Sybase (Windows, Solaris 32, HP, AIX)
»  Oracle (Windows, Solaris 32, Linux, HP, AIX)

This functionality is in addition to ODBC access on Windows, and it
replaces the RogueWave database interface on Solaris and other
UNIX platforms in previous versions of S-PLUS.

You can use the importData and exportData commands to access the
above databases using the new direct drivers.

Exporting to databases now allows existing tables to be either
replaced or appended to.

In addition, in S-PLUS for Windows, you can use the Import From
Database and Export to Database dialogs to access these databases
as data sources, just like accessing ODBC data sources. The previous
versions of S-PLUS had menu items such as Import Data » From
ODBC Connection and Export Data » To ODBC Connection,
and these have been replaced with Import From Database and
Export to Database, respectively. The dialogs presented now allow
you to select either ODBC or direct database sources from the same
list.

Direct database access is accomplished by using driver components
which must be separately installed on the system that is running
S-PLUS. These driver components are provided by the database
vendor and usually consist of components that can be called directly
by S-PLUS to send and receive database information in the native
format that the database supports. In many cases, direct database
drivers provide faster connectivity and data transfer than ODBC
because there are fewer layers of data translation and interpretation of
the request than with ODBC.
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S-PLus COMMANDS FOR IMPORTING AND EXPORTING

Before you can use the importData or exportData commands to
access database via the direct drivers, you must install database client
software on your system. Please refer to the sections below on
installing database clients for your system type.

There are four new database type keywords that can be used in the
type parameter of the importData or exportData commands:

* DIRECT-DB2
* DIRECT-ORACLE

DIRECT-SQL
DIRECT-SYBASE

As an example, consider the following S-PLUS commands to send
data to a Sybase database:

mydata <- data.frame(COLl=c(1.2,1.3,1.51,2.1,3.9),
COL2=c("a", "b", "c", "d", "e"™),
COL3=timeDate(c("1/1/2003", "2/1/2003",
"3/15/2005", "10/24/2003", "11/11/2004"),
format="%02m/%02d/%Y %02H:%02M:%02S.%03N"))

exportData(mydata, type="DIRECT-SYBASE",
user="testqga", password="testqga",
server="qgaimage.insightful.com", database="testdb",
table="testDirectSybase", appendToTable=F)

In this example, the data frame mydata is exported to the table
testDirectSybase into the database testdb on the server
gaimage.insightful.com. The database client software validates the
user and password parameter values prior to exporting the data, and
if they are incorrect, an error is reported in S-PLUS. The server name
you specify here should be the one you specified during installation of
the Sybase client software. See Step 6 in the Windows Sybase client
installation instructions below for further information on this.

Notice that the string DIRECT-SYBASE was used in the type parameter
of the exportData command to specify connection to a Sybase
database. Also note that the user name, password, server name,
database and table name are specified. For each of the four databases
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supported by direct drivers in S-PLUS, slightly different combinations
of these parameters must be specified. See the table below for a list of
the differences.

Table 1.1: Table of parameters required for various direct database types in importData and exportData.

Required parameters for

Database type importData and exportData Comments
DIRECT-DB2 user, password, database, Server parameter should
table not be specified for DB2.
DIRECT-ORACLE user, password, server, table Database parameter
should not be specified
for Oracle.

Server parameter should
be the network service
name you specified when
installing the Oracle
client software. See Step
5. in the section Oracle

Client.
DIRECT-SQL user, password, server, Serverpararneter should
database, table be the server name you

specified in the SQL
Server Enterprise
Manager program. See

Step 11. in the section
SQL Server 2000 Client.

DIRECT-SYBASE

user, password, server, Server parameter should
database, table be the server name you
specified in the Sybase
installation. See Step 6. in
the section Sybase Client.

Notice the existence of the appendToTable parameter, which controls
whether or not to append the data you are exporting to the specified
table. If this parameter is false, the data overwrites the table specified;
if true, the data is appended.
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An error occurs if the data types of the data you are sending and those
already present in the table do not match. For example, if you export
strings to a table that currently has columns of numeric values, you
receive an error and the export fails.

Here is an example of using the importData command to read data
into S-PLUS from an Oracle database table via the direct drivers:

mynewdata <- importData(type="direct-oracle",
user="testqga", password="testqga",
server="0RACLE.TESTDB",
table="testDirectOracle")

In this example, the table testDirectOracle is used. Since no specific
SQL query is specified (normally specified with the sq1Query
parameter), all data from the table is imported. The database client
software validates the user and password parameter values prior to
importing the data and if they are incorrect, an error is reported in
S-PLUS. The server name you specify here should be the one you
specified as the network service name during installation of the
Oracle client software. See Step 5. in the section Oracle Client
installation instructions below for further information on this.

For more information on using the importData and exportData
commands as well as additional information on using the sqlQuery
parameter in importData, please see the online help.
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DIALOGS FOR IMPORTING AND EXPORTING

Import From
Database

In S-PLUS for Windows, you can use the Import From Database and
Export to Database dialogs to access databases as data sources, just
like accessing ODBC data sources. The previous versions of S-PLUS
had menu items such as Import Data » From ODBC Connection
and Export Data » To ODBC Connection, and these have been
replaced with Import From Database and Export to Database,
respectively. The dialogs presented now allow you to select either
ODBC or direct database sources from the same list.

You can use the S-PLUS Import From Database dialog to import
table data from direct database sources available on your system.
Only those sources for which you have installed database clients are
supported. For more information on installing database client
software, see the section Installing and Configuring Database Clients
on UNIX and the section Installing and Configuring Database
Clients on Windows later in this document.

S-PLUS lists all data sources it supports in the Import From
Database dialog. However, only those sources which have database
clients installed on your system work. The others report errors until
you install and configure the appropriate database clients.

When you first run S-PLUS, four direct data sources are listed in the
Import From Database dialog, one for each type supported on
Windows:

*  Direct DB2

* Direct Oracle

*  Direct SQL Server
* Direct Sybase

You can modify these data sources to configure them for your
particular database setup, such as setting the correct server, database,
username, password, and other information appropriate for how the
database is set up on your network.
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You can also add new direct sources (based on one of the four types
listed above) to the list of data sources. This allows you to have one or
more data sources for the same database type, thus enabling you to
specify different database names or usernames and passwords to
access other sets of tables on the same database server.

You can also remove direct data sources from the Data Source list.
To import data from a direct database source:
1. From the File menu, select Import Data » From Database.
2. The Import From Database dialog appears, as shown in

Figure 1.1.
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Figure 1.1: The Import From Database dialog.

3. Select a direct data source from the Data Source list.

You can customize these or create new direct sources by
clicking the Add Sources button. See below for further
information on creating direct data sources.



Chapter 1 Using Direct Database Drivers

6.

Choose one of these or select another one you have created.

If you have not completely configured the source, the Modify
Data Source dialog appears. Fill in all the fields with valid
information for the data source chosen to continue.

Once a direct data source has been selected, the Tables list
changes to contain all the tables in that source. Select a table
from the list.

Specify any other options, including a valid SQL query in the
SQL Query field. If you leave the SQL Query field blank, a
default query of all columns and rows from the selected table
is performed.

Click the OK button to start the import.

You can add new direct data sources that are based on one of the four
supplied direct database types. You can add as many data sources as
you wish. To add a direct data source, do the following:

L.
2.

From the File menu, select Import Data » From Database.

Click the Add Sources button, and from the context menu,
select Add Direct Source.

The Add Direct Source dialog appears (Figure 1.2).

Add Direct Source x|

Specify the source for thiz direct databaze connection:
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Type: I Direct Oracle = l
Uszername: I
Password: I
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D atabase: I

()3 I Cancel | Hemove

Figure 1.2: The Add Direct Source dialog.
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Enter the name for the new direct data source in the Name
field. The name you enter is used to display this data source in
the list of data sources in the Import From Database and
Export To Database dialogs. Choose a name that is different
from other entries in the data sources list.

Select the type of database from the drop list of database
choices in the Type field.

Depending on the type you select, specify the username,
password, server and database name using the fields
provided. Some database types do not require a server or
database name, and so those fields may be unavailable.

Click OK to add the source to the data sources list. When you
add a source, it is also selected as the current source to import
from.

You can modify each of these with the appropriate information for
your database configurations. To modify a direct data source:

L.
2.

From the File menu, select Import Data » From Database.

Select the direct data source from the Data Sources list you
want to modify.

If the data source has invalid or incomplete information or
you are using the data source for the first time, the Modify
Data Source dialog appears, as shown in Figure 1.3.

Modify Direct Source x|
Specify the source for thiz direct databaze connection:
M ame: IDirect COracle

Type: I Direct Oracle = l
Username: ltestqa—
Password: I “““““““

Server IDHAELE.TESTDB

D atabase: I

()3 I Cancel | Remove

Figure 1.3: The Modify Direct Source dialog.
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Export to
Database

10

4. 1If the Modify Data Source dialog does not appear, it

7.

indicates that the information for this data source is valid.
Click the Modify Source button below the list to display the
Modify Data Source dialog.

In the Modify Data Source dialog, specify your user name
and password along with the server name and database name
for the source as appropriate for the database type. See Table
1.1 in the section S-PLUS Commands for Importing and
Exporting for help identifying which fields need to be filled
out for a given database type. The fields not required for a
given type are greyed out in the dialog.

You can also change the data source name shown in the
Name field and the database type shown in the Type drop
list. Changing the data source name changes how it is listed in
the Data Sources list in the dialog for both the Import and
Export dialogs. Changing the database type changes which
fields are available and may require you to specify different
information depending on the database type chosen. If you
change the database type, it is a good idea to change the name
to identify it as a different data source in the list.

Click the OK button to accept your changes.

You can also remove direct data sources. Be careful using this dialog,
as you can remove the four direct data sources that are provided with
S-PLUS. If you do, you can add them again following the procedures
above to add a data source. To remove a data source:

L.
2.

From the File menu, select Import Data » From Database.

Select the direct data source from the Data Sources list you
want to modify.

Click the Modify Source button. The Modify Direct Source
dialog appears.

Click the Remove button in this dialog to remove the data
source.

You can use the S-PLUS Export to Database dialog to export data
frame objects from S-PLUS to direct database sources available on
your system. Only those sources that you have installed database
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clients for are supported. For more information on installing database
client software, see the Installing and Configuring sections later in this
document.

S-PLUS lists all data sources it supports in the Export to Database
dialog. However, only those sources which have database clients
installed on your system work. The others sources report errors until
you install and configure the appropriate database clients.

When you first run S-PLUS, four direct data sources are listed in the
Export To Database dialog, one for each type supported on
Windows. These are listed as follows:

* Direct DB2

* Direct Oracle

* Direct SQL Server
* Direct Sybase

You can modify these data sources to configure them for your
particular database setup, such as setting the correct server, database,
username, password, and other information appropriate for how the
database is setup on your network.

You can also add new direct sources (based on one of the four types
listed above) to the list of data sources. This allows you to have one or
more data sources for the same database type, thus enabling you to
specify different database names or usernames and passwords to
access other sets of tables on the same database server. You can also
remove direct data sources from the data sources list.

To export data to a direct database source:

1. From the File menu, select the Export Data » To Database.

11
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2. The Export to Database dialog appears (Figure 1.4).
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Figure 1.4: The Export to Database dialog.

3. Select a data frame object to export from the Data frame list.
4. Select a direct data source from the Data Target list.

You can customize these or create new direct sources by
clicking the Add Targets button. See below for further
information on creating direct data sources.

Choose one of these or select another one you have created.

If you have not completely configured the source, the Modify
Data Source dialog appears. Fill in all the fields with valid
information for the data source chosen to continue.

5. Specify the table name you want to export to. Follow the
syntax rules for table names that the target database imposes.
Check your database documentation for more information on
this topic. By default, the table name shown is based on the
name of the data frame name specified in the dialog.
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You can append data to the table you specify if it already
exists in the database. To do this, check the Append to table
checkbox.

Note

If you try to append data that does not have columns which match the data types of columns that
already exist in the table, you will receive error messages and the export fails.

7.

Click the OK button to perform the export.

You can add new direct data sources that are based on one of the four
supplied direct database types, and you can add as many data sources
as you wish. To add a direct data source:

L.
2.

From the File menu, select the Export Data » To Database.

Click the Add Targets button and from the context menu
which appears, choose Add Direct Source, and a new dialog
appears.

Enter the name for the new direct data source in the Name
field. The name you enter is used to display this data source in
the list of data sources in the Import From Database and
Export to Database dialogs. Choose a name that is different
from other entries in the data sources list.

Select the type of database from the drop list of database
choices in the field called Type.

Depending on the type you select, specify the username,
password, server and database name using the fields
provided. Some database types do not require server or
database names and so that fields, so those fields may be
unavailable for those types.

Click OK to add the source to the data sources list. When you
add a source it is also selected as the current source to export
to.

You can modify each of these with the appropriate information for
your database configurations. To modify a direct data source:

1.

From the File menu, select the Export Data » To Database.

13
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2.

7.

Select the direct data source from the Data Target list you
wish to modify.

If the data source has invalid or incomplete information or
you are using the data source for the first time, the Modify
Data Source dialog appears.

If the Modify Data Source dialog does not appear, it means
that the information for this data source is valid. Click the
Modify Target button below the list to display the Modify
Data Source dialog.

In the Modify Data Source dialog, specify your user name
and password along with the server name and database name
for the source as appropriate for the database type. The fields
not required for a given type are unavailable (“grayed out”) in
the dialog.

You can also change the data source name shown in the
Name field and the database type shown in the Type drop-
down list. Changing the data source name changes how it is
listed in the lists in the dialog for both the Import From
Database and Export to Database. Changing which fields
are available may require you to specify different information
depending on the database type chosen. If you change the
database type, it is a good idea to change the name to identify
it as a different data source in the list.

Click the OK button to accept your changes.

You can also remove direct data sources. Use caution, as you can
remove the four direct data sources that are provided with S-PLUS. If
you do, you can add them again following the procedures above to
add a data source. To remove a data source:

L.
2.

From the File menu, select the Export Data » To Database.

Select the direct data source from the Data Target list you
wish to modify.

Click the Modify Target button, and the Modify Direct
Source dialog appears.

Click the Remove button in this dialog to remove the data
source.



How Direct
Data Sources
are Stored
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The entries in the data sources drop lists appearing in the Import
From Database and Export to Database dialogs are actually stored
in a special text file located in the .Prefs subfolder of your project
folder [S_PROJ]\.Prefs. The file is called datasources.ini, and can

be edited with any text editor.

Each line of the file is a comma-delimited specification of the
necessary information for the data source, as in the following
example:

DIRECTDB:Direct DB2,direct-db2,,testdb,testqa,testqa
DIRECTDB:Direct Oracle,direct-oracle,ORACLE.TESTDB, ,testqa,
DIRECTDB:Direct SQL Server,direct-sql,,,,

DIRECTDB:Direct Sybase,direct-sybase,qa.insightgul.com,,,

Each line must begin with the string DIRECTDB: This allows S-PLUS to
distinguish the information as pertaining to direct data sources.
Following this string, each field which appears in the dialog is entered
in the following order, with commas separating the fields:

[name], [typel, [server name], [database name], [usernamel],
[password]

where [name] is the data source name that appears in the drop-down
lists in the dialogs. The [type] field must be one of the following
(matching the type field in the importData and exportData
commands):

* direct-db2
* direct-oracle
* direct-sql
* direct-sybase
The [password] field must be specified as clear text.

Unspecified or blank field values must be separated by commas, as in
the example below where the database name and password fields are
left unspecified:

DIRECTDB:Direct Oracle,direct-oracle,ORACLE.TESTDB, ,testqa,

As an alternative to managing direct database sources in the dialogs,
you can simply edit this file after closing S-PLUS. Restart S-PLUS so
that the changes you made to the data sources in this file are used in
S-PLUS.

15
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INSTALLING AND CONFIGURING DATABASE CLIENTS ON

UNIX

16

In testing direct driver support on Linux and UNIX platforms, we
have found that the database vendors provide fairly complete
installation instructions regarding database clients on supported
platforms.

Please refer to the installation instructions that came with the database
software to install database clients on your system.
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INSTALLING AND CONFIGURING DATABASE CLIENTS ON

WINDOWS

SQL Server
2000 Client

In order to use direct database driver support in S-PLUS for Windows,
you must install database client software on the same system where
S-PLUS is installed. Currently, S-PLUS supports 32-bit versions of the
following database clients:

*  SQL Server 2000
* Sybase 12.5

*  Oracle 9i

« DB272

The SQL Server 2000 client supports access to a variety of SQL
Server versions, including SQL Server 6.5. The Oracle 9i client
supports access to most previous versions of Oracle, including 8i.

Other versions of the database clients may work but have not been
tested by Insightful.

You can follow the instructions provided by a database vendor to
install a database client. Alternatively, you can follow the steps below
for the appropriate client. These instructions are provided to help get
you started quickly installing and using a particular database client.
For more in-depth information, consult the instructions provided with
the database client software.

1. Insert the Microsoft SQL Server 2000 Enterprise Edition CD
in your CD-ROM drive and run English » Ent »
autorun.exe.

2. In the dialog that appears, select SQL Server 2000
Components from the available setup options.

3. In the next screen, select to install the Database Server.

4. In the next screen, select local computer, and select a
destination on your system.

5. In the next screen, select Create a new installation of SQL
Server, or Install Client Tools from the available options.

17
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6.

10.

11.

12.

13.

14.

In the next screen, choose Client Tools Only from the
available options

In the feature installation screen, accept all the selected
features — do not remove any!

Once installed, run the Enterprise Manager from the Start
menu using the icon at Programs » Microsoft SQL Server
» Enterprise Manager.

In the SQL Server Enterprise Manager window, there is a
sub-window called Console Root » Microsoft SQL
Servers. In the left pane of this window, expand the tree view
to Console Root » Microsoft SQL Servers » SQL Server
Group.

Right-click this expanded node and select New SQL Server
Registration from the menu.

In the Select a SQL Server dialog which appears, choose
the name of the server system you installed SQL Server on
from the list on the left, and click the Add button to add it to
the right.

In the dialog Select an Authentication Mode, choose the
radio button for SQL Server Authentication.

Next, specify the appropriate login name and password when
prompted.

Finally, choose to add the SQL server to the existing group
called SQL Server Group.

After you have successfully setup the client following the steps above,
ensure that the paths below are in your PATH environment variable:

[install path]\80\Tools\BINN

where [install path] is the path you chose to install the client tools
in step 4 above.
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Sybase Client Insert the Sybase 12.5 Adaptive Enterprise client CD into your CD-
ROM drive. The installation program should automatically start.

Note

If the Sybase installer crashes or locks up during startup in java.exe, then you may need to
disable Java “just-in-time” compiling on your system. See Sybase technical article
www.sybase.com/detail/1,6904,1013241,00.html on the Sybase Web site for more information

about this problem.

Carry out the following steps to install a Sybase client on your system:

L.
2.

Choose the Standard install.

Accept the default location or specify another location. Make
sure that the install directory you choose does not contain any
spaces.

Ensure that the following paths are in your PATH environment
value:

[install path]\CFG-1_0\bin;[install path]\0CS-
12_5\d11;[install path]\0CS-12_5\Tib3p;[install
path]\0CS-12_5\bin

where [install path] is the path you chose in step 2 above.

After installation, select Programs P Sybase » dsedit from the Start
menu to start this utility program. Then do the following steps:

L.

Click OK on the first screen to open the Interfaces Driver
screen.

From the Server Object menu, select Add.

In the Input Server Name box, enter the network internet
protocol name of the server running Sybase, and click OK

(e.g., qaimage.insightful.com).

In the attributes column of the Interfaces Driver dialog,
double-click the server address row.

In the Network Address Attribute window, click the Add
button.

Select TCP as the network connection protocol from the
drop-down list and enter

19
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[server ip name], 2048

in the Edit field. [server ip name] is the internet protocol name of
the server that has Sybase installed, and should be the same as
specified in step 3 above, as in qaimage.insightful.com. 2048 is the
port number it receives on, and you may have to change the port
number, depending on the server. Click OK to accept the changes.

The [server ip name] you specify here is used in S-PLUS to connect
to the server and use Sybase.

7.

10.
11.

Click OK to accept the Network Address Attribute
window.

Test the connection to the new server by selecting Ping from
the Server Object menu.

In the Ping dialog, click the Ping button. You should see
another dialog appear, indicating that the connection was
successful.

Close the dsedit utility program.

Test the connection using the Sybase ISQL utility:

*  Open a DOS Command window and type the following:
isql ~Utestqa -Ptestqa — S[server ip name]

+ At the isql program prompt, enter the following:

select * from pubs2.dbo.sales

go
After you type go, you should get an output table printed in
the window.

Oracle Client Insert the Oracle 9i Client for Win32 CD in your CD-ROM drive.
The setup starts automatically, and you can follow these steps:

L.

20

In the Oracle Universal Installer: File Locations dialog,
enter the path to install the Oracle client software on your
system in the Destination path field.

For the type of installation, select Administrator.

Use the default port number of 2030.
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After installation, the Oracle Net Configuration Assistant
automatically appears. If it does not automatically appear,
you can manually start it from the Start menu at Programs »
Oracle - OraHome90 » Configuration and Migration
Tools » Net Configuration Assistant.

In the Net Configuration Assistant Wizard, enter the
values specified in the appropriate wizard steps indicated
below:

*  Select Perform typical configuration in the Welcome
step. Click Next.

+  Select No, I will create net service names myself....
Click Next.

* Select Oracle8i or later database or service. Click
Next.

*  Specify an appropriate network service name. It is
suggested that you specify a name that contains the name
of the database and your network domain, as in
testdb.insightful.com for the service name. Click Next.

*  Select TCP as the protocol. Click Next.

*  Specify the name of the server which is running Oracle on
your network. Specify only the system name (and not an
IP address), such as qadb-s2k for the host name, and
specify an appropriate port number. You can accept 1521
as the default port or change it, depending on how your
server is configured. Click Next.

*  Select Yes, perform a test to test the connection. Click
Next. You should get an unsuccessful connection screen
with a Change Login button on it.

*  Click the Change Login button, and specify the
appropriate username and password in the dialog. Click
OK and then Next.

Now, the test connection should report success. Click Next.

Accept or change the network service name shown. This is the
name you specify in S-PLUS to access the ORACLE server.
Click Next.

21
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DB2 Client

22

8. When asked whether you want to configure another net
service name, choose No. Click Next.

After a successful installation, ensure that the following paths are in
your PATH environment value:

[install path]\ora90\bin

where [install path] is the path you chose during setup in step 1
above.

Insert the DB2 Universal Database Enterprise Edition Version 7.2 CD
into your CD-ROM drive. The installer should start automatically.

1. Choose Install from the list of setup options.

2. In the Select Products dialog, choose DB2 Administration
Client.

3. Select Typical setup type.

4. Select a destination for the installation or accept the default

path.

5. In the Enter Username and Password for Control Center

Server dialog, enter your network login name and password.

Note that you can enter another username and password, but

using your network login and password make it easy to
remember.

6. You may receive a dialog telling you that you don’t have

privileges to do certain things with DB2 on your system. Click

the OK button in this dialog to continue with the setup.

7. If you are prompted to restart your system, make sure you do
this. Some services that are installed as part of the DB2
installation need to be installed and mounted.

8. After your system is restarted or after the end of a successful
setup, the First Steps dialog appears. In this dialog, select
Catalog Sample Databases from the list on the left.

9. The Client Configuration Assistant is started.
10. In the Welcome dialog, click the Add Database button.



11.

12.

13.

14.

15.

16.

17.

18.

19.
20.

21.

Installing and Configuring Database Clients on Windows

A “wizard” dialog appears. In the Source page, click the
Search the network radio button, and switch to the
Database name page.

In the Tree view, expand the Other Systems node and wait
until the program has scanned all network systems for DB2
servers. The list it finds appears below this node.

Look for the name of the server that has DB2 installed on it in
this tree. If you don’t see it, check the server, and make sure
DB2 has been properly started. Once it is located, expand the
server name node in the tree to see a list of databases.

Select the database you want to use from the Local
databases node. The name appears in the Target Database
field at the bottom of the dialog. Click Next.

In the Alias page, verify that the alias for this database is
listed as the database name you chose. Click Next.

In the ODBC page, accept the defaults for registering the
database as a system source. Click Finish.

Click the Close button when a confirmation dialog appears.
Do not attempt to test the connection at this time as the
settings are not correct yet. You are then returned to the
Client Configuration Assistant main window.

You can see that the database you selected was added as a
database. Select this database, then click the Properties
button. This opens another dialog called Database
Properties - [database name].

Click the Properties button. This opens another dialog called
Update Connection Wizard - [database name].

Protocol should be set to TCP/IP. Click Next.

Correct the host name by changing it to the IP name of the
database server, such as qadb-snt.insightful.com. Click the
Finish button. You are returned to the Database Properties
- [database name] dialog. Click OK.

In the main Client Configuration Assistant window, select
the database you selected from the list and click the Test
button.
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22. In the Connect to DB2 Database, enter the appropriate
username and password in the fields and leave other default
settings. Click the OK button. You should receive a
“connection successful” dialog.

23. Close the Client Configuration Assistant.
24. Close the First Steps dialog.

25. Ensure that the path [install path]\BIN is in your PATH
environment value. [install path] is the path you selected
in step 4 above.
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