Insightful

the knowledge to act™

Getting Started with
S-PLUS® 8 for Windows®

May 2007

Insightful Corporation

Seattle, Washington




Proprietary
Notice

Copyright Notice

Trademarks

ii

Insightful Corporation owns both this software program and its
documentation. Both the program and documentation are
copyrighted with all rights reserved by Insightful Corporation.

The correct bibliographical reference for this document is as follows:

Getting Started with S-PLUS 8 for Windows, Insightful Corporation,
Seattle, WA.

Printed in the United States.

Copyright © 1988-2007, Insightful Corporation. All rights reserved.

Insightful Corporation

1700 Westlake Avenue N, Suite 500
Seattle, Washington 98109

USA

Insightful, Insightful Corporation, the Insightful logo and tagline

"the Knowledge to Act," Insightful Miner, S+, S-PLUS, S+FinMetrics,
S+EnvironmentalStats, S+SeqTrial, S+SpatialStats, S+Wavelets,
S+ArrayAnalyzer, S-PLUS Graphlets, Graphlet, Trellis, and Trellis
Graphics are either trademarks or registered trademarks of Insightful
Corporation in the United States and/or other countries. Intel and
Pentium are trademarks or registered trademarks of Intel Corporation
or its subsidiaries in the United States and other countries. Microsoft,
Windows, MS-DOS and Windows NT are either registered
trademarks or trademarks of Microsoft Corporation in the United
States and/or other countries. Sun, Java and Solaris are trademarks or
registered trademarks of Sun Microsystems, Inc. in the United States
or other countries. UNIX is a registered trademark of The Open
Group. Linux is a registered trademark of Linus Torvalds in the
United States and other countries.



ACKNOWLEDGMENTS

S-PLUS would not exist without the pioneering research of the Bell
Labs S team at AT&T (now Lucent Technologies): John Chambers,
Richard A. Becker (now at AT&T Laboratories), Allan R. Wilks (now
at AT&T Laboratories), Duncan Temple Lang, and their colleagues in
the statistics research departments at Lucent: William S. Cleveland,
Trevor Hastie (now at Stanford University), Linda Clark, Anne
Freeny, Eric Grosse, David James, José Pinheiro, Daryl Pregibon, and
Ming Shyu.

Insightful Corporation thanks the following individuals for their
contributions to this and earlier releases of S-PLUS: Douglas M. Bates,
Leo Breiman, Dan Carr, Steve Dubnoff, Don Edwards, Jerome
Friedman, Kevin Goodman, Perry Haaland, David Hardesty, Frank
Harrell, Richard Heiberger, Mia Hubert, Richard Jones, Jennifer
Lasecki, W.Q. Meeker, Adrian Raftery, Brian Ripley, Peter
Rousseeuw, J.D. Spurrier, Anja Struyf, Terry Therneau, Rob
Tibshirani, Katrien Van Driessen, William Venables, and Judy Zeh.

1ii



S-PLus BOOKS

iv

The S-PLUS® documentation includes books to address your focus
and knowledge level. Review the following table to help you choose
the S-PLUS book that meets your needs. These books are available in

PDF format in the following locations:

* In your S-PLUS installation directory (SHOME\help on
Windows, SHOME/doc on UNIX/Linux).

* In the S-PLUS Workbench, from the Help » S-PLUS Manuals

menu item.

+  In Microsoft® Windows®, in the S-PLUS GUI, from the

Help » Online Manuals menu item.

S-PLUS documentation.

Information you need if you... See the...
Are new to the S language and the S-PLUS GUIL, | Getting Started
and you want an introduction to importing data, | Guide

producing simple graphs, applying statistical

models, and viewing data in Microsoft Excel®.

Are a system administrator or a licensed user and
you need guidance licensing your copy of S-PLUS
and/or any S-PLUS module.

S-PLUS licensing Web
site
keys.insightful.com/

Are a new S-PLUS user and need how to use
S-PLUS, primarily through the GUL

User’s Guide

Are familiar with the S language and S-PLUS, and
you want to use the S-PLUS plug-in, or
customization, of the Eclipse Integrated
Development Environment (IDE).

S-PLUS Workbench
User’s Guide

Have used the S language and S-PLUS, and you
want to know how to write, debug, and program
functions from the Commands window.

Programmer’s Guide




S-PLUS documentation. (Continued)

Information you need if you...

See the...

Are familiar with the S language and S-PLUS, and
you want to extend its functionality in your own
application or within S-PLUS.

Application
Developer’s Guide

Are familiar with the S language and S-PLUS, and
you are looking for information about creating or
editing graphics, either from a Commands
window or the Windows GUI, or using S-PLUS-
supported graphics devices.

Guide to Graphics

Are familiar with the S language and S-PLUS, and
you want to use the Big Data library to import and
manipulate very large data sets.

Big Data
User’s Guide

Want to download or create S-PLUS packages for
submission to the Comprehensive S Archival
Network (CSAN) site, and need to know the steps.

Guide to Packages

Are looking for categorized information about
individual S-PLUS functions.

Function Guide

If you are familiar with the S language and S-PLUS,
and you need a reference for the range of statistical
modelling and analysis techniques in S-PLUS.
Volume 1 includes information on specifying
models in S-PLUS, on probability, on estimation
and inference, on regression and smoothing, and
on analysis of variance.

Guide to Statistics,
Vol. 1

If you are familiar with the S language and S-PLUS,
and you need a reference for the range of statistical
modelling and analysis techniques in S-PLUS.
Volume 2 includes information on multivariate
techniques, time series analysis, survival analysis,
resampling  techniques, and mathematical
computing in S-PLUS.

Guide to Statistics,
Vol. 2
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Chapter 1 Quick Tour

OVERVIEW

S-PLUS is designed to work seamlessly with the software you already
use. You can import data from and export data to many sources,
including spreadsheets such as Excel and Lotus, databases such as
Access, analytical software such as SAS and SPSS, and the financial
databases Bloomberg, LIM, and FAME. Once you have accessed
your data, you can analyze and explore them.

This quick tour briefly introduces you to many of the most commonly
used procedures in S-PLUS.



Getting Data

GETTING DATA

In this exercise, walk through an S-PLUS session using some built-in
sample data to help you decide which new car you should buy.

1. From the main menu, choose Data P Select Data to display
the Select Data dialog box, as shown in Figure 1.1.

Figure 1.1: The Select Data dialog box.

2. In the Source group, Existing Data is selected by default. In
the Existing Data group, type fuel.frame in the Name box.
(Disregard the Exclude big data objects check box)

3. Click OK to load the data into a Data window.

Figure 1.2: The fuel. frame data.
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The fuel.frame data set consists of five data columns plus a column
of row names:

*  Weight: Automobile weight in pounds

* Disp.: Engine displacement in cubic inches
* Mileage: Mileage in miles per gallon

*  Fuel: 100/Mileage

* Type: Category of vehicle (Large, Medium, Small, Compact,
Sporty, Van)

There are eight different column types in S-PLUS: character,
complex, double, factor, integer, Togical, single, and timeDate. To
see a DataTip displaying a column’s type, pause your cursor over the
column number.

Notice that Type is a factor column representing categorical data.



Creating a 2D Graph

CREATING A 2D GRAPH

Creating a graph in S-PLUS is easy: simply select your data columns
and click a plot button.

1. Select all the columns of fuel.frame (from Weight to Type) by
clicking and dragging the mouse across the column headers.

2. On the Standard toolbar, click the 2D Plots button il to
open a palette of available 2D plot types.

Figure 1.3: The 2D Plots button on the Standard toolbar.

3. Now click the Scatter Matrix button on the Plots 2D
palette.

Figure 1.4: The Scatter Matrix button on the Plots 2D palette.

Note

S-PLUS palettes and toolbars can be docked in place, dragged and dropped to create a floating
palette, or resized by dragging an edge.

As shown in Figure 1.5, the resulting scatterplot matrix displays each
column of data against the other selected columns. For example, to
see how Mileage and Fuel are related, read across from Mileage and



Chapter 1 Quick Tour

above Fuel to see the plot. The plot shows that Mileage and Fuel are
directly related. You can also see a strong relationship between
Mileage and Weight: heavier cars have lower mileage.
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Figure 1.5: The scatterplot matrix shows a number of strong relationships.



Performing a Linear Regression
PERFORMING A LINEAR REGRESSION

In this exercise, examine the relationship between Weight and
Mileage more extensively.

1. Close the Graph Sheet containing the scatterplot matrix.
You do not need to save it.

2. In the Data window, click the column header of Weight and
then CTRL-click the column header of Mileage so that both
columns are highlighted.

3. Now click the Linear Fit button L on the Plots 2D palette.

Figure 1.6: The Linear Fit button on the Plots 2D palette.
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Figure 1.7: Linear fit of Mileage vs. Weight.
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As shown in Figure 1.7, this linear fit shows an obvious relationship
between an increase in Weight and a decrease in Mileage.

To examine how vans or compact cars fit into this example, we can
use Trellis graphics to condition Weight and Mileage on a third
variable, Type.

4. From the main menu, choose Window P Tile Vertical (or

press CTRL-SHIFT-V) to vertically tile the Graph Sheet and
Data window side by side.

Select the Type column by clicking its header. (With your
windows tiled vertically, you may have to use the slider at the
bottom of the Data window to locate the Type column.)

Position your mouse within the data area (not the header area)
of the Type column; the cursor becomes a white pointer
arrow. (If positioned in the column header, the cursor
becomes a black down arrow.)

Now click and drag the column to the top of the Graph
Sheet until a rectangle marked by dashed lines appears. A
boxed plus sign beneath the mouse cursor indicates that you
have positioned the cursor correctly, as shown in Figure 1.8.
Release the mouse button to drop the column into this
rectangle and create the Trellis graph.

Figure 1.8: Drag and drop to create Trellis graphs.

The resulting plot is shown in Figure 1.9. Notice that the data are
divided into subsamples and conditioned by Type. Now you can see
additional relationships:

Sporty cars, normally assumed to be gas guzzlers, actually
have among the highest mileage, along with Sma11 cars.



Performing a Linear Regression

* Compact and Medium cars, often touted for higher mileage, get
gas mileage similar to Large cars.
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Figure 1.9: A Tiellis view of the fuel. frame data.
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IDENTIFYING AND LABELING DATA POINTS

In this exercise, identify which cars have the best and worst mileage
by labeling the data points.

1. Point the mouse cursor at any data point in the graph. A
DataTip (similar to a ToolTip) appears, displaying the
vehicle’s model, weight, and mileage.

2. Making sure that the Graph Sheet is in focus (so that the
Graph toolbar is displayed), click the Graph Tools button

on the Graph toolbar to open the Graph Tools palette, as
shown in Figure 1.10.

Figure 1.10: The Graph Tools button on the Graph toolbar.

3. Click the Label Point button * on the Graph Tools palette.

Figure 1.11: The Label Point button on the Graph Tools palette.

10



Identifying and Labeling Data Points

4. Click any data point. The data point is labeled with the car
description (the row name) and the values of the plotted
columns at that point. For example, if you click the uppermost
data point in the Large cars panel, you see the following label:

SHIFT-click additional points to label multiple points at once.
5. Click the Select Tool button X on the Graph Tools palette
and delete the labels by selecting them and pressing DELETE.
Next, change the contents of the DataTips and labels.

6. Right-click any data point in the plot and select Data to Plot
from the shortcut menu.

7. In the DataTips and Point Labels group, expand the
Column list.

8. Click <ROWNAMES> and then CTRL-click Disp.
9. Click OK.

The model name and engine displacement are now displayed in the
DataTips.

11
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EDITING A GRAPH

Imagine that you want to include your graph in a report or
presentation. In that case, you might want to further modify the
graph’s attributes.

In S-PLUS, graphics are object-oriented, which means you have
complete control over every detail. You can easily modify graph
objects using shortcut menus, dialog boxes, or the toolbar.

1. On the graph, click the x-axis title and then SHIFT-click the
y-axis title to select both titles. Each axis title is surrounded by
green knobs, indicating that it is selected.

2. Use the Graph toolbar to change the font size to 20.

3. Click any data point to select the plot. A single green square
appears on the plot indicating that it is selected.

4. Change the plot color to red. On the Graph toolbar, click the

the Line Color button L# and select Red from the dropdown
menu (see Figure 1.12).

Figure 1.12: The Line Color button can be used to change text color as well as line color.

12



Creating a 3D Graph

CREATING A 3D GRAPH

S-PLUS offers a variety of 3D plot types for powerful data
visualization. First, load some 3D data.

1. Close all open windows and palettes. (You do not need to save

any Graph Sheets.)

2. From the main menu, choose Data P Select Data to display
the Select Data dialog box.

3. In the Existing Data group, type galaxy in the Name box.
4. Click OK to load the data into a Data window.

Figure 1.13: The galaxy data.

The galaxy data set contains measurements of the radial velocity of a
spiral galaxy measured at 323 points in the sky.

5. Select the data columns east.west, north.south, and
velocity by CTRL-clicking each column header.

13
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6. On the Standard toolbar, click the 3D Plots button &=
open a palette of available 3D plot types.

Figure 1.14: The 3D Plots button on the Standard toolbar.

7. Now click the 3D Scatter button on the Plots 3D palette.

Figure 1.15: The 3D Scatter button on the Plots 3D palette.

The resulting graph is shown in Figure 1.16.
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Figure 1.16: A three-dimensional scatter plot of the galaxy data.
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Creating a 3D Graph

You can interactively rotate the 3D graph, both horizontally and
vertically.

8.

10.

11.

Click an empty space (but not a data point) within the plot
area to select the invisible 3D workbox. Four green circles and
a green triangle appear, indicating the workbox is selected.

Drag one of the green circles to rotate the plot horizontally.
When you release the mouse, the graph is redrawn at the new
perspective. The green triangle can be dragged up and down
to rotate the graph vertically.

Now click one of the plotted data points to select the scatter
plot. A single green box appears, indicating that the plot is
selected.

Click the 4 Panel Rotation button on the Plots 3D
palette. The resulting plot is shown in Figure 1.17.

X Angle = 60 X Angle = 150

Figure 1.17: Four-panel rotation of the galaxy data.

12. To rotate the graph, select the 3D workbox in the lower left

panel. All the panels will rotate together so that you can view
your graph from different angles.

15
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VIEWING OBJECTS AND DATABASES

The S-PLUS Object Explorer is a simple but powerful interface for
viewing, editing, manipulating, and organizing your S-PLUS objects.

1. Open the Object Explorer by clicking the Object Explorer
button B on the Standard toolbar.

Figure 1.18: The Object Explorer button on the Standard toolbar.

The Object Explorer uses folders to organize your objects. The first
time you open the Object Explorer, five default folders appear,
labeled Data, Graphs, Reports, Scripts, and SearchPath (see
Figure 1.19).

Figure 1.19: The Object Explorer.
Use the Object Explorer to locate the two built-in data sets,
fuel.frame and galaxy, that you have used in this quick tour.

2. In the left pane of the Object Explorer, click the plus (+) sign
to the left of the SearchPath icon to expand the SearchPath
folder.

16



Viewing Objects and Databases

3. Select the data subfolder in the left pane to display its
contents in the right pane.

4. Scroll through the right pane to locate the sample data sets
fuel.frame and galaxy.

Figure 1.20: The contents of the data database displayed in the right pane.

The objects displayed in the SearchPath folder are S-PLUS databases.
The first database in the search path is called the working data and is
the database in which S-PLUS automatically saves the data you create
and modify during a session. The remaining databases in the search
path are the system databases, which contain all the functions and data
objects that come with S-PLUS.

The SearchPath folder is handy for displaying the contents of any
S-PLUS database. By selecting a database in the left pane of the
Object Explorer, you can view its contents in the right pane.

17
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ORGANIZING YOUR WORK

By creating folders in the Object Explorer, you can organize the
work you do in S-PLUS. In this exercise, insert a new folder to
“contain” those objects associated with our current analysis.

L.

Deselect any selected folders or objects by clicking in the
white space of the left pane of the Object Explorer.

Click the New Folder button CJ on the Object Explorer
toolbar, as shown in Figure 1.21.

Figure 1.21: The New Folder button on the Object Explorer toolbar.

18

Name the folder Galaxy Project.

Display the contents of the data database by selecting it in the
left pane under Search Path.

In the right pane, select the galaxy data object by clicking its
icon; then drag and drop it into the Galaxy Project folder
you just created.

Click the Graphs folder icon to select it; the Graph Sheet
(6S1) open in your S-PLUS session appears in the right pane.
(Just as with any folder, you can click the plus (+) sign to the
left of the Graphs folder icon to expand your Graph Sheet
in the left pane.)

Drag and drop the GS1 object from the right pane into the
Galaxy Project folder.



Organizing Your Work

8. Select the Galaxy Project folder to view its contents in the
right pane, as shown in Figure 1.22.

Figure 1.22: Use the Object Explorer to view and organize the contents of your
session.

19
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Importing a File
IMPORTING A FILE

We begin this extended example by importing data from a SAS file. If
you have any windows or palettes open from the preceding tutorial,
close them before continuing.

To import the data:

1. From the main menu, choose File » Import Data » From
File. The Import From File dialog box opens, as shown in
Figure 2.1.

Figure 2.1: The Import From File dialog box.

2. Click Browse, navigate to the \library\exampleb folder in
your S-PLUS program folder, select exenvirn.sd2 as the file to
import, and click OK.

3. Click OK in the dialog box to import the data.

23
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Figure 2.2: The imported exenvirn data.
The exenvirn data set contains measurements on ozone

concentration, solar radiation, daily maximum temperature, and wind
speed on 111 days in 1973 in the New York metropolitan area.

24



Editing Variable Names and Adding Descriptions

EDITING VARIABLE NAMES AND ADDING DESCRIPTIONS

Variable Notice that the imported SAS file has variable names that are at most
Names eight characters long. In S-PLUS, variable names are more flexible, so
in this exercise, modify the variable names before creating a graph.

1. In the Data window, double-click the column name for
column 2 (radiatio), type Radiation, and then click OK.

2. Change the column name for column 3 from temperat to
Temperature.

3. For consistency, change the ozone and wind column names
to Ozone and Wind, respectively.

Column You can store more detailed information about your data set in
Descriptions column descriptions. Column descriptions are automatically used as
axis titles when graphing the data.

4. Right-click anywhere in the Radiation column to display the
shortcut menu for the column. Select Properties.

5. In the Description box, type Solar Radiation (langleys)
and click OK.

25
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CREATING A 2D GRAPH

You are ready to visualize the data. First, create a local regression plot
of the data.

L.

In the Data window, select the Radiation column and then
CTRL-click to select 0zone so that both columns are
highlighted. (The first column will be the x data, and the
second will be the y data.)

Click the 2D Plots button to open the Plots 2D palette.

Click the Loess button & on the Plots 2D palette. A locally
weighted, least squares regression is calculated, and the plot is
created.

Close the Plots 2D palette.

Click the maximize button in the upper right corner of the

Graph Sheet.

Right-click any data point (or the smoothed line) and select
Smooth/Sort from the plot’s shortcut menu.

Note

If you do not see a Smooth/Sort option in the shortcut menu, you probably selected another
graph object. Try again, making sure you click a data point and not the plot area, an axis, or an
axis label. S-PLUS indicates selected graphics objects with green knobs. Try clicking different
parts of the graph (axis, labels, data, etc.) to see how different graph objects are highlighted with
green knobs when they have been selected. See Selecting Graph Objects on page 74 for more

details.

26

Try different levels of smoothing. In the Loess/Friedman
Specs group, enter values between 0.1 and 0.9 in the Span
box and click Apply.

Reset the Span to Auto and click OK.



Changing Graph Features

CHANGING GRAPH FEATURES

Axes and
Labels

Plot Properties

S-PLUS gives you unparalleled control over every detail of your
graph, right down to the thickness of the tick marks. You can control
all individual line thicknesses, symbol sizes, fonts, colors, titles, tick
marks, and axis labels. Additionally, you can create multiple lines of
text for comments, titles, and tick labels. Superscript and subscript
options are conveniently located on the Graph toolbar for quick
access so editing text or equations is easy.

7.
8.

Click the y axis to select it. (A square green knob appears on
the center of the axis if you have properly selected it.)

CTRL-click the x axis to select it.

From the main menu, choose Format » Selected Objects.
The Modify All Selected Objects (if applicable) dialog
box opens, displaying the Display/Scale page.

In the Color box, select Lt Gray.
In the Frame box, select With ticks.

Click the Grids/Ticks tab. In the Major Ticks group, in the
Weight box, select 1.

In the Tick Position box, select In.
Click OK.

In the following steps, change the y-axis title.

9.

10.

11.

12.

Click once to select the axis title (green knobs surround the
axis title when it is selected), and then click once more to
open an in-place edit box.

In the text edit box, type Ozone Concentration. Do not
press ENTER; rather, click outside the box to accept the
change.

Right-click any data point (or the smoothed line) and select
Line from the plot’s shortcut menu. (A green knob appears at
the bottom of the graph indicating the plot object is selected.)

In the Color box, select Black; in the Weight box, select 2.

27
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13. Click the Symbol tab to display the Symbol page of the
dialog box. In the Style box, select Circle, Solid. In the
Color box, select Red.

14. Click OK.

Titles In this section, insert a main title at the top of the graph.
15. From the main menu, choose Insert » Titles » Main.

16. In the resulting text edit box, type The Relationship
Between Radiation and Ozone. Do not press ENTER;
rather, click outside the title to close the text box.

Use the toolbar to change the font, font size, and color of any text
objects in your graph.
17. Select the main title and use the toolbar to specify a font size
of 20.

18. Click the Line Color button L# on the Graph toolbar and
change the text color to Blue.

The Relationship Between Radiation and Ozone

Ozone Concentration

0 50 100 150 200 250 300 350
Solar Radiation (langleys)

Figure 2.3: After you change the graph, it looks like this.

Do not close the Graph Sheet or Data window; you will use them
again shortly.
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USING TRELLIS GRAPHICS FOR MULTIPANEL
CONDITIONING

Suppose you have a data set with multiple variables, and you want to
see how plots of two variables change with variations in one or more
conditioning variables. Trellis graphics are designed to display your
data in a series of panels conditioned upon different values of one or
more specified variables. Each panel contains a subset of the original
data corresponding to intervals of the conditioning variables.

Most S-PLUS graphs can be conditioned. The data columns used for
each plot and for the conditioning variable(s) must be of equal length.
By default, the axis specifications and panel display attributes (for
example, fill color) are identical for each panel.

Apply multipanel conditioning to our previously created loess plot.

1. Make sure that only the windows containing the exenvirn
data and your Graph Sheet are open. From the main menu,
choose Window P Tile Vertical.

2. In the Data window, select Temperature and then CTRL-click
to select Wind.
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Figure 2.4: Temperature and Wind are dragged to the rectangular drop target at
the top of the graph.
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3. As illustrated in Figure 2.4, click and hold the mouse in the

data area of the columns and then drag and drop them onto
the rectangular drop target that appears at the top of the
graph.

The resulting Trellis graph (see Figure 2.5) shows how the
dependence of 0zone on Radiation varies according to levels of Wind
and Temperature.

Ozone Concentration

The Relationship Between Radiation and Ozone
0 100 200 300

Wi Wi
Temperature: 57.0 to 79.0 Temperature: 79.0 to 98.0
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Solar Radiation (langleys)

Figure 2.5: Ozone concentration and solar radiation: This graph shows that
radiation explains variation in ozone levels beyond that explained by wind speed and
temperature.
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4. Select the plot by clicking a line or symbol in any one of the

panels.
Open the Plots 2D palette and click the Linear Fit button

£ A linear regression line replaces the loess curve in each
panel, as shown in Figure 2.6. This graph suggests that high
temperatures with less wind result in the strongest
dependence of ozone on radiation.



Using Trellis Graphics for Multipanel Conditioning

The Relationship Between Radiation and Ozone

0 100 200 300
Wi Wi
7.0t0 79.0 Temperature:
° L]
L]
. L] . L] 4
° < : o
c o
kel .
g ° 2
€
Q 3
e
8 ind: 2.310 9.7 ind: 2.3109.7
) 7.0t0 79.0 Temperature:
S
N
O
4
. '. ° .
.——r - ° L]
L]
2
0 100 200 300

Solar Radiation (langleys)

Figure 2.6: A linear regression has replaced the loess curve in each panel.
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HIGHLIGHTING DATA POINTS

You can highlight data points in the graph and have the same points
highlighted in the Data window, as well as in other graphs.

1. To open the Graph Tools palette, click the Graph Tools
button ET in the Graph toolbar.

9. Click the Select Data Points button E=.

3. Drag around a selection of points in the upper right panel of
the graph.

Notice that the selected points are highlighted in both the graph and
the Data window. If we had other Graph Sheets open based on
these data, the points would also be highlighted in these other graphs.

4. Click an empty part of a panel to remove the selection.
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EXTRACTING GRAPH PANELS

It is easy to “drill down” into a Trellis graph panel using buttons on
the Graph Tools palette.

I. Click the Extract Panel button B on the Graph Tools

palette.

Click the lower left panel of the Trellis graph. The panel is
extracted and displayed as a full-sized graph, as shown in
Figure 2.7.

The Relationship Between Radiation and Ozone

Temperature >= 57.000000and Temperature < 79.000000and Wind >= 2.300000and Wind < 9.700000

3.5
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0 50 100 150 200 250 300
Solar Radiation (langleys)

Figure 2.7: A panel extracted from a Trellis graph.

3. Click the Show All Panels button H to restore the Trellis

graph.

From the main menu, select File » Save As, and then
navigate to your current project folder (typically
C:\Documents and Settings\username\My Documents\
S-PLUS Projects\Projectl). Save the multipanel plot as
mpanel.sgr.
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5. Leave the exenvirn Data window open, but close the Graph
Sheet and any open palettes.

Note

The data are not saved with the Graph Sheet. When the Graph Sheet is reopened, it redraws
using the current data set named exenvirn. To embed the data within the Graph Sheet before
saving, choose Graph » Embed Data from the main menu. See the section Embedding and
Extracting Data in Graph Sheets on page 45 for more details.
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APPLYING STATISTICAL MODELS

Summaries

S-PLUS provides a vast array of statistical techniques, with the most
widely used techniques accessible through dialog boxes launched
from the Data and Statistics menus.

All techniques available on the menus are also available through the
S-PLUS language. Use commands either interactively in the
Commands window, or as script in a Script window. In the course of
an analysis, you may find it convenient to begin by fitting a model
through a handy dialog box, and then proceed to analyze the model
and perform diagnostics through the flexible and powerful S
language.

In this section, fit linear regression models to predict ozone using
temperature, radiation, and wind.

Examine the simple summaries of the exenvirn data.

1. From the main menu, choose Statistics » Data Summaries
» Summary Statistics to display the Summary Statistics
dialog box.

2. In the Data group, exenvirn appears by default in the Data
Set box.

3. Click OK to display summaries for the data columns in a
Report window.

4. From the main menu, choose Statistics ™ Data Summaries
» Correlations to display the Correlations and
Covariances dialog box.

5. In the Data group, exenvirn appears by default in the Data
Set box.

6. Click OK. The correlations for the data columns are added
beneath the summaries in the Report window.

7. Close the Report window (do not save it).
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Linear Models In this section, use the Linear Regression dialog box to fit a linear
model predicting 0zone from the other variables.

Simple Model L.
From a Dialog
Box

5.
6.
7.

In the Data window, select 0zone, Radiation, Temperature,
and Wind, in that order, by dragging across the column
headers.

From the main menu, choose Statistics » Regression »
Linear to display the Linear Regression dialog box.

In the Data group, exenvirn appears by default in the Data
Set box.

In the Formula box of the Variables group, examine the
expression Ozone ~ Radiation + Temperature + Wind.
Listed first is the response variable, 0zone. This response was
chosen because 0zone was the first column you selected. The
predictor variables, shown after the tilde (~), represent the
other variables in the order in which they were selected.

Click the Plot tab to display the Plot page.
In the Plots group, select the Residuals vs Fit check box.
Click OK.

The regression results appear in the Report window. In addition, a
new Graph Sheet displays the diagnostic plot.

Note

The data used in this plot are embedded within the Graph Sheet. Subsequent changes in the
exenvirn data set will not affect these plots.

The Formula Using the Formula Builder, you can describe complex regression
Builder models by selecting variables and indicating how they are used in the
model. For example, you might want to add an interaction term to the

model.
8. Close the Graph Sheet and the Report window and click the
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Data window, outside the selected data, to clear the selection.

From the main menu, choose Statistics » Regression »
Linear to display the Linear Regression dialog box.



More Detailed
Results

10.

11.

12.

13.

14.

15.

16.

18.

19.

20.

21.

22.

23.

Applying Statistical Models

In the Variables group, from the dropdown list in the
Dependent box, select Ozone.

Using CTRL-click, select Radiation, Temperature, and Wind
from the dropdown list in the Independent box. Notice that
the formula reflects your changes.

Click the Create Formula button to display the Formula
dialog box.

In the Variable group, in the Choose Variables box, CTRL-
click to select Radiation and Temperature.

In the Add group, click Interaction to include the interaction
between radiation and temperature as a predictor.

Click OK to close the Formula dialog box. The formula you
generated appears in the Formula box of the Linear
Regression dialog box.

Click OK to generate the model.

Close the Report window.

From the main menu, choose Statistics » Regression »
Linear to display the Linear Regression dialog box again.

Click the Dialog Rollback button H (located at the bottom
center of the dialog box page, just to the right of the Apply
button) to select the previous dialog box state. The previous
values for Data Set and Formula are filled in.

Click the Results tab to display the Results page of the dialog
box.

In the Printed Results group, select the ANOVA Table
check box. This selection provides an analysis of variance
table for the linear model.

Click OK. The ANOVA table for the fit appears in the
Report window below the regression results.

When you finish examining the results, close the Report
window and the exenvirn Data window.
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DOING MORE WITH GRAPHICS

Varying 2D
Axes Types

38

By default, 2D plots are drawn on linear x and y axes. Sometimes it is
useful to create plots using a logarithmic or probability scale on one
or both axes. You can create such plots by selecting the 2D axis type
from the toolbar before selecting the plot type.

1. From the main menu, choose Data P Select Data to display
the Select Data dialog box.

2. In the Existing Data group, type Puromycin in the Name
box.

3. Click OK to load the data into a Data window.

Figure 2.8: The Puromycin data.

The Puromycin data set is from a biochemical experiment testing the
drug Puromycin. The column conc gives the enzyme concentration of
the substrate, and ve1 is the initial velocity of the reaction. The state
variable indicates whether or not the cell has been treated with
Puromycin.

4. Select the columns conc, vel, and state by dragging the
mouse across the column headers.



Doing More With Graphics

5. From the Standard toolbar, choose Log X from the Default
2D Axes Type dropdown list.

Figure 2.9: Changing the default 2D axes type.

6. Open the Plots 2D palette and click the Color button |—
The treated and untreated cell observations appear in
different colors.

7. Make sure the graph is not selected, and then change the
Default 2D Axes Type back to Linear.

Note

The Default 2D Axes Type control specifies the default axes type. In this example, if you do not
change it back to Linear, subsequent plots will be created on a log scale as well. If your graph is
selected when you change the default axes type, the axes type of your selected graph will also be
changed.

8. Close the Graph Sheet, the Data window, and the Plots 2D
palette.

Creating You can create plots showing different data series, with varying scales,
Graphs With against a single x or y variable. This is often useful in plotting revenue
and profit (for example) against time. You can see at a glance whether
revenue and profit are rising and falling together or if some more
complicated relationship holds.

Multiple Axes

As a simple example, plot housing starts and manufacturing
shipments on a time scale.

1. From the main menu, choose File » Load Library to
display the Load Library dialog box, as shown in Figure
2.10.
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Figure 2.10: The Load Library dialog box.

2.

In the Library Name box, select exampleb and click OK to
load the library.

Open the sample data set econ.df by using the Object Explorer.

3.

Click the Object Explorer button B on the Standard
toolbar.

In the left pane of the Object Explorer, click the plus (+) sign
to the left of the SearchPath icon.

Expand the example5 folder by clicking the plus (+) sign to
the left of its icon.

Select econ.df in the left pane to display its columns in the
right pane. Notice that this sample data set contains two
columns of class ts (years and hstart) and one column of
class structure (ship).

In the left pane of the Object Explorer, double-click the icon
to the left of econ.df.

Figure 2.11: Data objects containing columns of certain classes must be opened in
read-only mode.
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8. Because econ.df contains columns of class ts and class
structure, which are not supported in the Data window (see
page 4), S-PLUS warns you that it will be opened in read-only
mode. Click the Open read-only button to continue.

Hint

In read-only mode, columns in the Data window are slightly shaded.

9. With econ.df displayed in a read-only Data window, click

the Convert to Data Frame button B on the Data window
toolbar, as shown in Figure 2.12.

Figure 2.12: The Convert to Data Frame button on the Data window toolbar.

10. The Convert Object to Data Frame dialog box is displayed,
as shown in Figure 2.13.

Figure 2.13: The Convert Object to Data Frame dialog box.

11. In the Data Frame Name text box, type my.econ.

12. Click OK to convert the data object and display it in a new
Data window.
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Figure 2.14: The converted my.econ data.

13. In the my.econ Data window, select the columns years,
hstart, and ship by dragging the mouse across the column
headers.

14. From the main menu, choose Graph » 2D Plot to display
the Insert Graph dialog box.

15. Under Axes Type, select Multiple Y. Under Plot Type,
select Scatter Plot (x, yl, y2, ...). Accept the default Graph
Sheet, GS1, and click OK.

A plot appears with hstart plotted along the left y axis, ship along
the right y axis, both plotted against years along the x axis. You could
also create this plot by selecting Multiple Y as the default axes type
on the main toolbar, and then clicking the Scatter button on the 2D
Plots palette.

16. From the main menu, choose Insert » Legend. A legend
appears, along with the Legend dialog box. Click OK to
dismiss the dialog box and drag the legend to the upper left of
the plot. The resulting graph is shown in Figure 2.15.
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Figure 2.15: A plot with multiple y axes.

Doing More With Graphics
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Another way to show data series with varying scales is to put the
series in separate panels.

17. Select the rectangular plot area defined by the axes. Change
the Default 2D Axes Type on the Standard toolbar to Vary

Y Panel.-
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The graph is redrawn, placing each plot in a separate panel, as shown
in Figure 2.16. The y axis is scaled separately in each panel.
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Figure 2.16: Two data series with varying scales in separate panels.
18. Make sure the plot is not selected, and then change the
Default 2D Axes Type back to Linear. Close the Data

windows.
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EMBEDDING AND EXTRACTING DATA IN GRAPH SHEETS

You can store the data used to create any graph within the Graph
Sheet. Using this feature, you can provide a fully editable graph to
friends or colleagues without also having to provide a separate data
file.

Embed the my.econ data in the Graph Sheet.
1. Make sure the Graph Sheet is in focus.
2. From the main menu, choose Graph » Embed Data.

You can also extract the data embedded in any Graph Sheet for
further analysis or manipulation.

Extract the my.econ data we just embedded in the Graph Sheet.
3. Make sure the Graph Sheet is in focus.

4. From the main menu, choose Graph P Extract Data to
display the Extract Data dialog box.

5. Specify a name (such as my.econ2) for the extracted data set
and click OK.

6. Close the Graph Sheet, saving it as econ.sgr.

Before proceeding, close all open windows except the Object
Explorer.
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CREATING A GRAPH USING THE OBJECT EXPLORER

In addition to helping you organize your objects, the Object
Explorer is a handy tool for manipulating them. It can be
particularly useful when creating graphs from a data set with many
columns.

1. With the Object Explorer in focus and the example5 folder
expanded in the left pane, double-click the icon to the left of
the sample data set state.df to display the data in a Data
window.

Figure 2.17: The state.df data.
The state.df data set has columns showing information about states
in the United States.

2. In the left pane of the Object Explorer, click the icon to the
left of state.df to display its columns in the right pane.

3. Click the icon next to Income; then CTRL-click Illiteracy
and then Area. Notice that these columns are now also
selected in the Data window.
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Editing a Plot
in the Object
Explorer

Viewing Plots
in Separate
Panels

Creating a Graph Using the Object Explorer

4. Close the Data window; in this exercise, you use the Object
Explorer for graphing.
5. Open the 2D Plots palette and click the Loess button [

Two loess plots are created in a Graph Sheet, both scaled to the
same set of axes.

Using the Object Explorer and properties dialog boxes, you can edit
any open Graph Sheet. As an example, change the format of the x
axis labels.

6. With the Object Explorer in focus, expand the Graphs
folder in the left pane.

7. Expand GS1 (or the graph sheet name that corresponds to the
plot you just created).

8. Expand Graph2D and then click Axis2dX1, both in the left

pane.

9. In the right pane of the Object Explorer, double-click
Axis2DLabelX to open the X Axis Labels properties dialog
box.

10. In the Label 1 group, change the Type box from Auto to
Decimal and make sure Precision is set 1.

11. Click OK.

Relationships between variables can be seen much more clearly if
they are scaled to different y axes. One way to do this is to view the
plots in separate panels, keeping the x-axis scaling the same.

12. Click a blank spot anywhere inside the axes region to select
the graph.

13. Click the Graph Tools button BT on the Graph toolbar.

14. On the Graph Tools palette, click the Separate Panels with
Varying Y Axes button =]

The plots now appear in two panels, stacked one over the other.
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Removing Notice that there is one data point far from the others. If you place
Outliers your cursor at that point, you see that it represents Alaska. Remove
this outlier from the plots.

15. Click the Select Data Points button &8 on the Graph Tools
palette.

16. In either panel, drag a rectangle around the point
representing Alaska to select it.

17. From the main menu, choose Format » Exclude Selected
Points.

The loess smoothing is recalculated, and the points representing
Alaska are removed from the plots, as shown in Figure 2.18.
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Figure 2.18: Separate panel plot with outlier excluded.

18. Click the Select Tool button 3 to return to the selection
Cursor.

19. Close all open windows and palettes.
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CREATING A 3D GRAPH

In this exercise, use the data set exsurf to create a 3D plot.

1. From the main menu, choose Data P Select Data to display
the Select Data dialog box.

2. In the Existing Data group, type exsurf in the Name box.
3. Click OK to load the data into a Data window.

Figure 2.19: The exsurf data.

4. Now select the columns V1, V2, and V3 by dragging the mouse
across the column headers.

5. Click the 3D Plots button &=
open the Plots 3D palette.

on the Standard toolbar to

6. Click the Spline Surface button & on the Plots 3D palette.
The resulting graph is shown in Figure 2.20.
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Figure 2.20: 3D spline plot of the exsurf data.
Adding Color In this section, add color draping to the spline plot.
Draping 7. Click the maximize button in the upper right corner of the
Graph Sheet.
8. Click the mesh of the surface plot to select it.
Click the 32 Color Surface button & on the Plots 3D
Ealette. The graph redraws with the new format, as shown in
igure 2.21.
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Figure 2.21: Color draping can be done with up to 64 colors

10. Close all open windows and palettes.



Creating PowerPoint Slides

CREATING POWERPOINT SLIDES

If you have PowerPoint installed on your computer, you can
automatically create a PowerPoint presentation from your S-PLUS

graphs.
Use the graphs you saved during this tutorial to create a PowerPoint
presentation.

I. Click the PowerPoint Presentation button @8 on the

Standard toolbar.

Figure 2.22: The PowerPoint Presentation button on the Standard toolbar.

4.
5.

The Welcome screen of the PowerPoint Presentation
Wizard is displayed.

Click Next.

Click Add Graph to locate your graphs (mpanel.sgr and
econ.sgr) and then add them to the list for your presentation.

Click Next to move to the next page of the wizard.
Click Finish.

PowerPoint opens and the graphs are inserted as slides in a new
PowerPoint presentation. Note that the graphs are inserted in the
order you specified in the wizard’s presentation list.
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USING S-PLus WITH MICROSOFT EXCEL

Creating Excel
Data Inside
S-PLus

52

In addition to being able to exchange data with Microsoft Excel, you
can also open Excel worksheets from directly within S-PLUS, making
your Excel data instantly available for creating graphics and
performing statistical analyses.

Create a data set representing a sinusoidal function in an Excel
worksheet, and then plot it and test for serial correlation using S-PLUS.

Create the data set in an Excel worksheet within S-PLUS.

1. From the main menu, choose File » New to open the New
dialog box.

2. Select Microsoft Excel Worksheet and click OK.

An Excel worksheet entitled SplusBook1 appears, as shown in Figure
2.23.

Figure 2.23: An Excel worksheet created from within S-PLUS.

3. Incell C5, type the number 1 and press ENTER.
4. Select cell C6.

5. On the Formula toolbar, click the Edit Formula button
(marked by an equals sign). An equals sign appears in the
Formula text box.

6. In the Formula text box, immediately after the equals sign,
type C5+1 and press ENTER.



Plotting Excel
Data

Analyzing Excel
Data

Using S-PLUS With Microsoft Excel

The number 2 appears in cell C6, and cell C7 is highlighted.
7. Select cell C6 and press CTRL-C.
8. Select cells C7 through C34 and then press CTRL-V.

Column C, rows 5 through 34, should now contain the values from 1
through 30.

9. Select cell D5.
10. On the Formula toolbar, click the Edit Formula button.

11. In the Formula text box, immediately after the equals sign,
type 3*SIN(C5) *2 and press ENTER.

The number 2.12422 appears in cell D5, and cell D6 is highlighted.
12. Select cell D5 and press CTRL-C.
13. Select cells D6 through D34 and then press CTRL-V.

Column D, rows 6 through 34, should fill with values between 0 and
3, inclusive.

Create an S-PLUS graph from our data.
14. Select cells C5 through D34.
15. On the Standard toolbar, click the 2D Plots button il to
open the Plots 2D palette.
16. Click the Line button ¥ to create a line plot of the data.

Behind the scenes, a linkhas been created between Excel and S-PLUS.

Use the autogenerated link between Excel and S-PLUS that was just
created to compute the autocorrelation function on our Excel data.

17. From the main menu, choose Statistics ™ Time Series P
Autocorrelations to open the Autocorrelations and
Autocovariances dialog box.

18. In the Object dropdown list of the Data group, select
SplusBook1.Sheet1.C5.D34, which is the link object.

19. In the Variable dropdown list, select V2 and then click OK.
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A Report window displays the autocorrelation matrix, and a plot is
created showing that significant serial correlation appears in the
series, as we would expect. See Figure 2.24.

Series : SplusBook1.Sheetl.C5.D34[["V2"]]

1.0

ACF
0.0

Lag
Figure 2.24: The autocorrelation matrix and plot for our Excel data.

As our plot example shows, S-PLUS automatically creates a link
whenever you select a region of an Excel worksheet and attempt to
create a plot. Similarly, it automatically creates a link if you select
some data and try to perform a statistical analysis.
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For most purposes, these automatically created links are all you need.
However, you can have more control over the link if you create it
with the Link Wizard. Use the Link Wizard if you need to specify row
and column names for the data you select or if you want to modify
the data formats S-PLUS uses to display the linked data. For detailed
information on using the Link Wizard, see Chapter 10, Using S-PLUS
with Other Applications, in the User’s Guide.
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USING THE S-PLus LANGUAGE

For some analyses, it is more convenient to work with an interactive
data analysis language than to maneuver through a series of dialog
boxes. The Commands window provides that interactive access to
the S-PLUS language.

In this section, use the Commands window to fit another linear
model and perform some diagnostics.

1. Close all open windows.
2. Open the Commands window by clicking the Commands
Window button 3 on the Standard toolbar.

Figure 2.25: The Commands window button on the Standard toolbar.

S-PLus
Language
Basics

56

Everything you type in S-PLUS is an expression, and expressions are
evaluated when you press the ENTER key. Most S-PLUS expressions
are function calls since S-PLUS is a functional language. To call a
function, simply type the name of the function followed by any
arguments to the function enclosed in a set of parentheses.
Remember that S-PLUS commands are case-sensitive.

The Commands window uses a > prompt. If you press ENTER after
an expression that is syntactically incomplete, it is not evaluated
immediately. Instead, S-PLUS prompts you to continue the expression
with the + continuation prompt.

You can type several expressions on the same line by separating them
with semicolons (;). S-PLUS evaluates each in succession when you
press ENTER. A semicolon is not required at the end of each line, only
between multiple expressions on a single line.

You can include comments in S-PLUS expressions by inserting them
after a # symbol. Anything after the # on a line is interpreted as a
comment and is not evaluated.



Using the S-PLUS Language

The result of any S-PLUS expression is an object that you can save by
assigning it a name using the assignment operator <-. Each data set
used in S-PLUS is represented as an S-PLUS data object of a certain
class.

Note

The assignment operator is typed by typing a “less than” character (<) followed immediately by a
hyphen (-). Be careful not to put any spaces between these two characters.

Listing Objects

S-PLUS ignores most spaces, so you can include or omit spaces in
typing your expressions as you prefer. However, do not place extra
spaces in the name of an object, between the digits of a single
number, or between the < and - in the assignment operator.

In the following examples, text appearing after the > symbol is to be
typed at this prompt. Do not type the > or the first + at the beginning
of a line.

In this section, replicate the regression results obtained earlier using
the exenvirn data and store them in an object named fit.Tm.

3. At the prompt in the Commands window, type the following
(remember that the S-PLUS language is case-sensitive):

> fit.Im <- Tm(0zone~Radiation+Temperature+Wind,
+ data=exenvirn)

4. Now, to see a brief summary for the model, type

> fit.1Im
to display a brief summary for the model:
Call:

Im(formula = Ozone ~ Radiation + Temperature + Wind,
data = exenvirn)

Coefficients:

(Intercept) Radiation Temperature Wind
-0.2973296 0.002205541 0.05004432 -0.07602195
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Degrees of freedom: 111 total; 107 residual
Residual standard error: 0.5101592

You can extract the specific model components of fitted values,
coefficients, and residuals using the specific extraction functions
fitted, resid, and coef. For example, to extract the coefficients from
fit.Im, use coef as follows:

> b <- coef(fit.Im)
> b[2]

Radiation
0.002205541

When fitting the model using dialog boxes, you added one interaction
term to examine the interaction between temperature and radiation
in determining ozone level. Now fit a model containing interactions
and explore whether the interactions are significant.

5. To fit a linear model with all two-way interactions, type

> fit.int <- Tm(Ozone~(Radiation+Temperature+Wind)"2,
+ data=exenvirn)

6. For a brief summary of the fit, type

> fit.int

7. For a detailed summary, type

> summary(fit.int)
8. For an F-test comparing this model to the model fit above,
type

> anova(fit.Im, fit.int)

The Script window makes it easy to edit and run several lines of
commands. You can copy and paste expressions from the
Commands window into a Script window, and then save the script
as an external (.ssc) file.

Create and run a new S-PLUS language script. Start by copying and
pasting the two expressions we typed in the Commands window.

9. From the main menu, choose File » New.
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10. Select Script File and click OK.

11. Click the title bar of the Commands window to make it the
active window.

12. Copy and paste the following two lines from the Commands
window into the new Script window, being careful to exclude
the > prompt as you highlight each line:

fit.Im <- Tm(Ozone~Radiation+Temperature+Wind,data=exenvirn)
fit.1m

13. Click the Run button “* on the Script window toolbar.

The script output appears in the lower pane, as shown in Figure 2.26.

Figure 2.26: Output displayed in the lower pane of the Script window.
14. Close the Commands and Script windows (do not save
script).
Notice that there is no prompt in the Script window. To run a script,

simply click the Run button " on the Script window toolbar or
press F10. To run only selected commands, first highlight them, and

then click the Run button “* or press F10. (If no output appears in
the lower pane, choose Options P> Text Output Routing and select
Script Output in both columns.)
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GETTING HELP IN S-PLus

HTML Help Online help is available for both the S-PLUS graphical user interface
and the S-PLUS programming language. From the main menu:

* Choose Help » Available Help » S-PLUS Help to access
the online help for the graphical user interface.

* Choose Help P Available Help » Language Reference to
access the online help for the S-PLUS programming language.

Online help in S-PLUS is based on Microsoft Internet Explorer and
uses an HTML window to display the help files.

Figure 2.27: The S-PLUS Help window.

As shown in Figure 2.27, the HTML Help window has three main
areas: the toolbar, the left pane, and the right pane.
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Using the Toolbar Table 2.1 lists the four main buttons on the help window toolbar (in
some cases, you might see more).

Using the Left
Pane

Using the Right
Pane

Table 2.1: Help window toolbar buttons.

Button Name Description

Hide (or Show) If the button is labeled Hide, it hides the

left pane. If the button is labeled Show, it
shows the left pane.

Back Returns to previously viewed help topic.
Forward Moves to next help topic.
Print Prints the current help topic.

The left pane contains three tabs: the Contents tab, the Index tab,
and the Search tab:

The Contents tab organizes help topics by category so that
related help files can be found easily. These categories appear
as small book icons, labeled with the name of the category. To
open a category, double-click the icon or label. To select a
topic within the category, double-click its question-mark icon
or the topic title.

The Index tab lists available help topics by keyword.
Keywords are typically function names for S-PLUS language
functions and topic names for graphical user interface topics.
Simply type in a keyword and HTML Help will find the
keyword that most closely matches it. Click Display (or
double-click the selected title) to display the help topic.

The Search tab provides a full-text search for the entire help
system. Simply type in a keyword, and all the help files
containing that keyword are listed in a list box. Select the
desired topic and click Display (or double-click the selected
title) to display the help topic.

The right pane contains the help topic. It usually appears with both
vertical and horizontal scroll bars, but you can expand the HTML
Help window to increase the width of the right pane. Many help files
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are too long to be fully displayed in a single screen, so choose a
convenient height for your HTML Help window and then use the
vertical scroll bars to scroll through the text.

The right pane contains a search-in-topic feature. To use it:

1. Type CTRL-F to open the Find dialog box (this dialog box is a
feature of HTML Help inherited from Internet Explorer).

2. Type your search string in the Find what box.
3. Click Find Next.

When you work in the Commands window, you can get help for any
command by using the ? or help function. For example, to open the
help file for anova, simply type:

> help(anova)

or

> ?anova

To get help for a command when you are working in a Script
window, highlight the command and press F1.
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USING MENUS

Main Menus

S-PLUS menus change, depending upon the type of window currently
in focus. For example, if the active window (the highlighted window)
is a Data window, the menus display options useful for operating on
Data windows; some Graph Sheet and programming options are
absent or dimmed.

Menu options ending with a P symbol display a submenu when
selected. Menu options ending with an ellipsis (...) display a dialog
box when selected. To cancel a menu, simply click outside the menu
or press ESC.

Figure 3.1: Choosing Nonlinear Regression from the Statistics menu.

Shortcut
(Right-Click)
Menus

64

When you click the right mouse button, a shortcut menu for the
selected object is displayed. Shortcut menus contain options specific
to the selected object and appear to the right or left of the mouse
pointer. To close a shortcut menu without selecting an option, simply
click outside the menu or press ESC.



Using Dialog boxes

USING DIALOG BOXES

The Apply
Button

Sometimes when you choose a menu option or click the mouse,
S-PLUS displays a dialog box. You can use dialog boxes to specify
information about a particular action.

There are two types of dialog boxes in S-PLUS: action dialog boxes
and properties dialog boxes. Action dialog boxes carry out
commands, such as copying a column. Properties dialog boxes
display, and allow you to modify, the properties or characteristics of
the selected object.

Dialog boxes can contain multiple tabbed pages containing different
options. To access a particular page, click on its tab, or press CTRL-
TAB, to move from page to page. When you click OK or Apply (or
press ENTER), any changes you made on any of the tabbed pages are
applied to the selected object.

Most of the dialog boxes in S-PLUS are modeless: They can be moved
around on the screen, and they remain open until you choose to close
them. This means you can make changes in a dialog box and see the
effect without closing the dialog box using the Apply button. This
feature is useful when you experiment with changes to an object and
want to see the effect of each change.

Modeless dialog boxes have an Apply button. The Apply button acts
much like the OK button, except that it does not close the dialog box.
By specifying changes in a dialog box and clicking Apply (or pressing
CTRL-ENTER), you can see the effect of your changes while keeping
the dialog box open, so that you can make additional changes without
having to reselect the dialog box.

If no changes have been made using the dialog box since it was last
opened or “applied,” the Apply button is dimmed. To close the
dialog box, click the Cancel button or the close button in the upper
right corner of the dialog box.
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The Dialog
Rollback
Buttons

Typing and
Editing in
Dialog Boxes

Each time you make changes to a dialog box and click OK or Apply,
S-PLUS remembers the changes and keeps track of the final “state” of
the dialog box. The Dialog Rollback buttons, located at the bottom
center of the dialog box, let you restore a dialog box to a prior state.

You can use the buttons to scroll back through each of the prior states
of a dialog box until you find the set of values you want. By clicking
OK or Apply, you can restore an object to a previous state.
Alternatively, you can save time by using a prior state as a starting
point for further changes.

Note that Dialog Rollback is different from Undo in that rollback
can be applied selectively to individual objects.

Table 3.1 below lists the shortcut keys you can use in dialog boxes for
performing the associated tasks.

Table 3.1: Shortcut keys when using dialog boxes.

box.

Action Shortcut Key
Move to the next option in the dialog box. TAB

Move to the previous option in the dialog box. | SHIFT-TAB
Move between pages in a multipage dialog | CTRL-TAB

Move to a specific option and select it.

ALT-underlined letter in the option name (Press
again to move to the next option with the same
underlined letter.)

Display a dropdown list.

ALT-down arrow

66




Using Dialog boxes

Table 3.1: Shortcut keys when using dialog boxes. (Continued)

Action

Shortcut Key

Select an item from a list.

Up or down arrow to move, ALT-down arrow
to close the list

Close a list without selecting any items.

ALT-down arrow
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USING TOOLBARS AND PALETTES

ToolTips

68

In addition to the Standard toolbar, which is always displayed,
S-PLUS displays a special toolbar, depending upon the type of
window that is currently open and active. For example, when a Data
window is the active window, S-PLUS opens the Data window
toolbar; when a Graph Sheet is in focus, the Graph toolbar is
displayed. Toolbar buttons provide convenient shortcuts to a number
of menu selections. Note that you cannot turn off the display of the
Standard and special toolbars.

When you position the mouse pointer over a toolbar button, a
description appears in the status bar at the bottom of the screen. Like
menu options, some toolbar buttons may not be available at all times.
Inactive toolbar buttons are dimmed; for example, the Undo button
is dimmed if there is nothing to undo.

In addition to toolbars, several buttons display a palette of options
when selected. For example, the 2D Plots button displays a palette of
2D plot types. Tool palettes remain in view until you click the toolbar
button again or click the palette’s close box. Leaving a tool palette in
view is convenient when you experiment with different options.

When you hover the mouse over a toolbar or palette button, helpful
ToolTips appear:

To turn off this feature, choose Options » General Settings from
the main menu and clear the Enable ToolTips check box on the
General page of the dialog box.



DataTips

Using Toolbars and Palettes

DataTips are much like ToolTips except that they display information
about data in the active Data window or Graph Sheet. For example,
when you pause your mouse over a point in a scatter plot, or over the
column number in a Data window, a DataTip displays information
relevant to that point:

To turn off this feature, choose Options » General Settings from
the main menu and clear the Enable DataTips check box on the
Data page of the dialog box.
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SELECTING DATA

Using the
Select Data
Dialog Box

Using the
Object
Explorer
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You can select data using either the Select Data dialog box or the
Object Explorer. If you want to open the data in a Data window so
that the data are visible as you work, the Select Data dialog box is
simplest and fastest. If you want to work with many separate data
objects with which you are already somewhat familiar, the Object
Explorer can be much more efficient.

From the main menu, choose Data P Select Data to display the
Select Data dialog box. In the Source group, Existing Data is
selected by default. In the Existing Data group, type a data object
name or select a data object from the dropdown menu in the Name
box. Click OK to load the data into a Data window.

Click the Object Explorer button B on the Standard toolbar. To
select a data object, simply click its name in either pane of the Object
Explorer. To display the data in a Data window, double-click the
icon to the left of the data object’s name.



Importing Data

IMPORTING DATA

You can import data from a file, from the leading financial databases
Bloomberg, FAME, and MIM, or via an ODBC connection. ODBC
connections allow you to extract data sets from enterprise databases.
In all cases, there are numerous options you can specify.

For the simplest case in which you want to read an entire data file,
choose File » Import Data » From File from the main menu. In
the Import From File dialog box, navigate to the appropriate folder
and select the desired file. Click OK.

For detailed information on how to import data from a financial
database or via an ODBC connection, consult the User’s Guide and
the online help.
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SELECTING VARIABLES TO PLOT

Selecting
Variables in a
Data Window

Selecting
Variables in
the Object
Explorer
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You create a plot by selecting variables from a given data set and then
choosing a plot type, either by a clicking a plot palette button or by
selecting the plot type in the Insert Graph dialog box. You can select
your variables in either a Data window or the Object Explorer.

+ To select two or more contiguous variables, click and drag the
mouse across the column headers.

+ To select a range of variables, click the column header of the
first variable, and then SHIFT-click the column header of the
last variable in the range. All the variables between the
variable in which you first click and the variable in which you
SHIFT-click are selected.

* To select noncontiguous variables, or to select variables in a
particular order, click the column header of the first variable,
and then CTRL-click the column headers of the other desired
variables.

* To select a range of variables, click one variable name, and
then SHIFT-click another. All the variables between the
variable you first click and the variable you SHIFT-click are
selected.

* To select noncontiguous variables, click one variable name,
and then CTRL-click one or more other variable names.



CREATING PLOTS

Creating Plots

After you select the variables to plot, click a plot palette button, or
select the plot type by choosing Graph from the main menu.

For your reference, Table 3.2 below shows the plot types most
commonly associated with a given number of selected variables.

Table 3.2: Common plots associated with a given number of variables.

Number of
Selected Variables

Plots

1

Box, QQ normal with line, probability,
probability normal with line, histogram, density,
histogram density, pie, dot, bar.

QQ), probability, Pareto, scatter, line, line with
scatter, line with isolated points, step, high
density, curve fit (linear, polynomial, exponential,
power, log 10, natural log), nonlinear curve fit,
smoothing (loess, spline, robust LTS, robust MM,
kernel, Friedman), Y series, grouped box, polar.

Text as symbols, grouped bar with error, 3D
scatter, 3D line, 3D line with scatter, 3D scatter
with dropline, 3D regression, 3D regression with
scatter, bubble, color, error bar, scatterplot
matrix, contour (line or filled), 3D contour (line or
filled), levels, 3D surface, 3D bar, comment,
Smith.

4 or more

XY pairs, grouped bar, stacked bar, bubble color,
high-low-close, high-low-open-close, candlestick,
error bar-both, vector, area, Smith.
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SELECTING GRAPH OBJECTS

To edit graphics, first select the object to edit. In S-PLUS, we
distinguish between the Graph Sheet, the graph area, and the plot
area, as illustrated in Figure 3.2.

Graph Sheet (can contain more than one graph)

graph area (axes, labels, etc.)

plot area (data)

Figure 3.2: A Graph Sheet depicting the graph area (gray) and plot area (center
white).

* The Graph Sheet can best be thought of as the sheet of paper
on which you draw your plots. It can contain one or more

graphs. When you print, you print one or more pages of a
Graph Sheet.

* The graph area refers to the rectangle surrounding the data
points, axes, legends, titles, and so on.

* The plot area is the rectangular area within the graph area
where the data are actually plotted.

Within the plot area, you can select the plot area, the plot
itself, or any plotted element:

+  To select the plot, click any plotted element (line, symbol,
filled region, etc.).

+ To select the plot area, click a blank area within the plot
area.
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Figure 3.3 shows the difference in how S-PLUS displays the
two selections.

Figure 3.3: Selecting the plot versus selecting the plot area.

To select a plot element, such as an axis, axis title, or axis label, simply
click it.

Axes and axis titles are editable and selectable separately on 2D
graphs. Axis labels are formatted per axis.
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